Okay
  Public Ticket #3170330
Introduction field dissappears
Open

Comments

  • whereisanthony started the conversation

    I've been having an issue with our calendar events in Stachethemes Event Calendar. After the event has passed, we often place a Vimeo video embed code in the Introduction field. For some reason, on random events, the video embed code in the event introduction field gets removed or the code gets altered to where the video will not play anymore. 

    Our Introduction field gets replaced with this:

    <div style="padding: 75% 0 0 0"></div>

    Does anyone know what might be causing this or how we might prevent this issue?

  •  587
    Zhivko replied

    Hi,

    Could you send me the video embed code to test it out?


    Stachethemes Developer

  • whereisanthony replied

    The video embed text looks like this. 

    This is actually a video that disappeared from the event

    <div style="padding:56.25% 0 0 0;position:relative;"><iframe src="https://player.vimeo.com/video/761943579?h=3691f6f76d" style="position:absolute;top:0;left:0;width:100%;height:100%;" frameborder="0" allow="autoplay; fullscreen; picture-in-picture" allowfullscreen=""></iframe></div><script src="https://player.vimeo.com/api/player.js"></script>
    <p><a href="https://vimeo.com/761943579">October 18 2022 Committee of the Whole and Budget</a> from <a href="https://vimeo.com/user97934148">Benton County</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
    

    It was replaced with the following 

    <div style="padding: 56.25% 0 0 0"></div>
    


  •  587
    Zhivko replied

    I can't reproduce this problem.

    Do you have this problem on our live admin demo here:

    https://stachethemes.com/wp-demos/tbb/wp-admin/

    user /pass : demo / demo


    Stachethemes Developer

  • whereisanthony replied

    So I created an event with the embed code below in the introduction field, and I couldn't even get it keep the iframe when I clicked save or update. It stripped out the iframe tags and just left the <p> text below it. 

    <iframe src="https://player.vimeo.com/video/196277011?h=f9328d3d50&color=ffffff&title=0&byline=0&portrait=0&badge=0" width="640" height="360" frameborder="0" allow="autoplay; fullscreen; picture-in-picture" allowfullscreen=""></iframe>
    <p><a href="https://vimeo.com/196277011">The 12 Days of Christmas - A Tale of Avian Misery</a> from <a href="https://vimeo.com/blinkprods">Blink</a> on <a href="https://vimeo.com">Vimeo</a>.</p>
    

    Here's the event I created "Holiday Event test (id#305703)" in the admin and https://stachethemes.com/wp-demos/tbb/stec_event/holiday-event-test/ on the front end.


  •  587
    Zhivko replied

    When you paste the html make sure the editor is in "text" mode:

    5939486434.png



    Stachethemes Developer

  • whereisanthony replied

    Yup, I did that.

  •  587
    Zhivko replied

    I can't reproduce this problem. Video attached.

    Attached files:  video.zip


    Stachethemes Developer